re = /type=dog[\s\S]*?name=(\w+)[\s\S]*?(color=(\w+))?/m
str = 'type=dog
sex=male
name=wolf
color=brown
type=dog
sex=male
name=bob
type=cat
sex=male
name=tom
color=black
type=dog
sex=female
name=simona
color=white'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end