import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type=dog[\\s\\S]*?name=(\\w+)[\\s\\S]*?(color=(\\w+))?";
final String string = "type=dog\n"
+ "sex=male\n"
+ "name=wolf\n"
+ "color=brown\n"
+ "type=dog\n"
+ "sex=male\n"
+ "name=bob\n"
+ "type=cat\n"
+ "sex=male\n"
+ "name=tom\n"
+ "color=black\n"
+ "type=dog\n"
+ "sex=female\n"
+ "name=simona\n"
+ "color=white";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}