const regex = /type=dog[\s\S]*?name=(\w+)[\s\S]*?(color=(\w+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type=dog[\\s\\S]*?name=(\\w+)[\\s\\S]*?(color=(\\w+))?', 'gm')
const str = `type=dog
sex=male
name=wolf
color=brown
type=dog
sex=male
name=bob
type=cat
sex=male
name=tom
color=black
type=dog
sex=female
name=simona
color=white`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}