# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ABC(?:\n.+)*/TEST/gm;t' <<< "ASDFABC
ABC
ABC
ABC
ASDF
ASDF
ASDF
ASDFABC"