#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ABC(?:\n.+)*"
Local $sString = "ASDFABC" & @CRLF & _
"ABC" & @CRLF & _
"ABC" & @CRLF & _
"ABC" & @CRLF & _
"" & @CRLF & _
"ASDF" & @CRLF & _
"ASDF" & @CRLF & _
"ASDF" & @CRLF & _
"ASDFABC"
Local $sSubst = "TEST"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)