use strict;
my $str = 'ASDFABC
ABC
ABC
ABC
ASDF
ASDF
ASDF
ASDFABC';
my $regex = qr/^ABC(?:\n.+)*/mp;
my $subst = 'TEST';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";