$re = '/^ABC(?:\n.+)*/m';
$str = 'ASDFABC
ABC
ABC
ABC
ASDF
ASDF
ASDF
ASDFABC';
$subst = "TEST";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;