import re
regex = re.compile(r"^ABC(?:\n.+)*", flags=re.MULTILINE)
test_str = ("ASDFABC\n"
"ABC\n"
"ABC\n"
"ABC\n\n"
"ASDF\n"
"ASDF\n"
"ASDF\n"
"ASDFABC")
subst = "TEST"
result = regex.sub(subst, test_str)
if result:
print(result)