package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)R['’]?e['’]?n['’]?e['’]?e['’]?s`)
var str = `Basically I want to show Renee’s and Renee's in the paragraph displayed to the user and highlight the whole word even if the user searches for Renees.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}