re = /R['’]?e['’]?n['’]?e['’]?e['’]?s/m
str = 'Basically I want to show Renee’s and Renee\'s in the paragraph displayed to the user and highlight the whole word even if the user searches for Renees.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end