$re = '/R[\'’]?e[\'’]?n[\'’]?e[\'’]?e[\'’]?s/m';
$str = 'Basically I want to show Renee’s and Renee\'s in the paragraph displayed to the user and highlight the whole word even if the user searches for Renees.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);