// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)R['’]?e['’]?n['’]?e['’]?e['’]?s").unwrap();
let string = "Basically I want to show Renee’s and Renee's in the paragraph displayed to the user and highlight the whole word even if the user searches for Renees.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}