# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\W+([a-zA-Z])\b/$1/gm;t' <<< "Anti-Candida a ингибинов"