package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\W+([a-zA-Z])\b`)
var str = `Anti-Candida a ингибинов`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}