$re = '/\W+([a-zA-Z])\b/m';
$str = 'Anti-Candida a ингибинов';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;