import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:void|unsigned|signed|long|short|float|double|int|char|\\*)(?:\\s*))+)(\\w+)\\s*\\(";
final String string = "#include <stdio.h>\n\n"
+ "unsigned int* fun1(void);\n\n"
+ "double u;\n\n"
+ "signed \n"
+ " long long \n"
+ " int function1 ( int j, int n);\n\n"
+ "void main(int) {\n"
+ " int ii;\n"
+ " double jj;\n"
+ " long kk;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}