import re
regex = re.compile(r"((?:(?:void|unsigned|signed|long|short|float|double|int|char|\*)(?:\s*))+)(\w+)\s*\(", flags=re.DOTALL | re.MULTILINE)
test_str = ("#include <stdio.h>\n\n"
"unsigned int* fun1(void);\n\n"
"double u;\n\n"
"signed \n"
" long long \n"
" int function1 ( int j, int n);\n\n"
"void main(int) {\n"
" int ii;\n"
" double jj;\n"
" long kk;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")