re = /((?:(?:void|unsigned|signed|long|short|float|double|int|char|\*)(?:\s*))+)(\w+)\s*\(/m
str = '#include <stdio.h>
unsigned int* fun1(void);
double u;
signed
long long
int function1 ( int j, int n);
void main(int) {
int ii;
double jj;
long kk;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end