$re = '/((?:(?:void|unsigned|signed|long|short|float|double|int|char|\*)(?:\s*))+)(\w+)\s*\(/sm';
$str = '#include <stdio.h>
unsigned int* fun1(void);
double u;
signed
long long
int function1 ( int j, int n);
void main(int) {
int ii;
double jj;
long kk;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);