#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""^\s{1}\S*?\s{1}$""
Local $sString = " or "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)