use strict;
my $str = ' or ';
my $regex = qr/"^\s{1}\S*?\s{1}$"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";