import Foundation
let pattern = #""^\s{1}\S*?\s{1}$""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" or "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)