using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[(Administrators)(LOCAL SERVICE)(NETWORK SERVICE),\s]+$";
string input = @"Administrators,LOCAL SERVICE,NETWORK SERVICE
LOCAL SERVICE,NETWORK SERVICE, Administrators
Administrators,LOCAL SERVICE,NETWORK SERVICE,phil";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}