#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^.*_(\d+\.dcm)"
Local $sString = "Albert_Silva-MR11_0.dcm"
Local $sSubst = "slice_$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)