$re = '/^.*_(\d+\.dcm)/';
$str = 'Albert_Silva-MR11_0.dcm';
$subst = "slice_$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;