const regex = /^.*_(\d+\.dcm)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*_(\\d+\\.dcm)', '')
const str = `Albert_Silva-MR11_0.dcm`;
const subst = `slice_$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);