use strict;
my $str = 'Albert_Silva-MR11_0.dcm';
my $regex = qr/^.*_(\d+\.dcm)/p;
my $subst = 'slice_$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";