re = /^.*_(\d+\.dcm)/
str = 'Albert_Silva-MR11_0.dcm'
subst = 'slice_$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result