import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*) - (.*)";
final String string = "CHBS Vol 05 - Lonesome Blues\n"
+ "CHBS Vol 05 - Lonesome Blues - and some other text\n"
+ "Text before - and after\n"
+ "Text 1 - Text 2 - Text 3 - Text 4";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}