re = /(.*) - (.*)/
str = 'CHBS Vol 05 - Lonesome Blues
CHBS Vol 05 - Lonesome Blues - and some other text
Text before - and after
Text 1 - Text 2 - Text 3 - Text 4'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result