// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*) - (.*)").unwrap();
let string = "CHBS Vol 05 - Lonesome Blues
CHBS Vol 05 - Lonesome Blues - and some other text
Text before - and after
Text 1 - Text 2 - Text 3 - Text 4";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}