const regex = new RegExp('(.*) - (.*)', 'g')
const str = `CHBS Vol 05 - Lonesome Blues
CHBS Vol 05 - Lonesome Blues - and some other text
Text before - and after
Text 1 - Text 2 - Text 3 - Text 4`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);