import re
regex = re.compile(r"(.*) - (.*)")
test_str = ("CHBS Vol 05 - Lonesome Blues\n"
"CHBS Vol 05 - Lonesome Blues - and some other text\n"
"Text before - and after\n"
"Text 1 - Text 2 - Text 3 - Text 4")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)