import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z][a-zA-Z0-9]{1,3}) ?(\\d[a-zA-Z]{2})";
final String string = "EC1A 1BB\n"
+ "A9A 9AA\n"
+ "A9 9AA\n"
+ "A99 9AA\n"
+ "AA9 9AA\n"
+ "AA99 9AA\n"
+ "EC1A1BB\n"
+ "A9A9AA\n"
+ "A99AA\n"
+ "A999AA\n"
+ "AA99AA\n"
+ "AA999AA";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}