# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z][a-zA-Z0-9]{1,3}) ?(\d[a-zA-Z]{2})"
test_str = ("EC1A 1BB\n"
"A9A 9AA\n"
"A9 9AA\n"
"A99 9AA\n"
"AA9 9AA\n"
"AA99 9AA\n"
"EC1A1BB\n"
"A9A9AA\n"
"A99AA\n"
"A999AA\n"
"AA99AA\n"
"AA999AA")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.