re = /([a-zA-Z][a-zA-Z0-9]{1,3}) ?(\d[a-zA-Z]{2})/im
str = 'EC1A 1BB
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
EC1A1BB
A9A9AA
A99AA
A999AA
AA99AA
AA999AA'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result