// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)([a-zA-Z][a-zA-Z0-9]{1,3}) ?(\d[a-zA-Z]{2})").unwrap();
let string = "EC1A 1BB
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
EC1A1BB
A9A9AA
A99AA
A999AA
AA99AA
AA999AA";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}