const regex = new RegExp('<body[^>]*class *= *["\\\\']\\K', '')
const str = `<body class="old_attr">
<div>(content)</div>
</body>`;
const subst = `new_class_attr `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);