use strict;
my $str = '<body class="old_attr">
<div>(content)</div>
</body>';
my $regex = qr~<body[^>]*class *= *["\']\K~p;
my $subst = 'new_class_attr ';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";