$re = '~<body[^>]*class *= *["\']\K~';
$str = '<body class="old_attr">
<div>(content)</div>
</body>';
$subst = "new_class_attr ";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;