re = /<body[^>]*class *= *["\']\K/
str = '<body class="old_attr">
<div>(content)</div>
</body>'
subst = 'new_class_attr '
result = str.sub(re, subst)
# Print the result of the substitution
puts result