import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^;]*;){4}([^;]*;[^;]*);";
final String string = "42441;27;nombre;apellidos;direccion; 8-2º; SEVILLA;SEVILLA;12345;texto;123456789;;test@gmail.com;123456;;1900-08-20;1904-06-30 00:00:00;0000-00-00 00:00:00;2;1;0000-00-00;0000;1111;1111;11;0123456789;;18;0;0;2;15;ES11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}