re = /^(?:[^;]*;){4}([^;]*;[^;]*);/
str = '42441;27;nombre;apellidos;direccion; 8-2º; SEVILLA;SEVILLA;12345;texto;123456789;;test@gmail.com;123456;;1900-08-20;1904-06-30 00:00:00;0000-00-00 00:00:00;2;1;0000-00-00;0000;1111;1111;11;0123456789;;18;0;0;2;15;ES11'
# Print the match result
str.match(re) do |match|
puts match.to_s
end