use strict;
my $str = '42441;27;nombre;apellidos;direccion; 8-2º; SEVILLA;SEVILLA;12345;texto;123456789;;test@gmail.com;123456;;1900-08-20;1904-06-30 00:00:00;0000-00-00 00:00:00;2;1;0000-00-00;0000;1111;1111;11;0123456789;;18;0;0;2;15;ES11';
my $regex = qr/^(?:[^;]*;){4}([^;]*;[^;]*);/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}