import Foundation
let pattern = #"^(?:[^;]*;){4}([^;]*;[^;]*);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"42441;27;nombre;apellidos;direccion; 8-2º; SEVILLA;SEVILLA;12345;texto;123456789;;test@gmail.com;123456;;1900-08-20;1904-06-30 00:00:00;0000-00-00 00:00:00;2;1;0000-00-00;0000;1111;1111;11;0123456789;;18;0;0;2;15;ES11"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}