#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:B*A){3}B*$)(?=(?:A*B){2}A*$)[AB]{5}$"
Local $sString = "AAABB" & @CRLF & _
"ABABA" & @CRLF & _
"BAABA" & @CRLF & _
"ABAAB" & @CRLF & _
"ABCDE" & @CRLF & _
"BBBAA" & @CRLF & _
"ABBAB" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")