$re = '/^(?=(?:B*A){3}B*$)(?=(?:A*B){2}A*$)[AB]{5}$/m';
$str = 'AAABB
ABABA
BAABA
ABAAB
ABCDE
BBBAA
ABBAB
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);