re = /^(?=(?:B*A){3}B*$)(?=(?:A*B){2}A*$)[AB]{5}$/m
str = 'AAABB
ABABA
BAABA
ABAAB
ABCDE
BBBAA
ABBAB
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end