using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:B*A){3}B*$)(?=(?:A*B){2}A*$)[AB]{5}$";
string input = @"AAABB
ABABA
BAABA
ABAAB
ABCDE
BBBAA
ABBAB
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}