import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:B*A){3}B*$)(?=(?:A*B){2}A*$)[AB]{5}$";
final String string = "AAABB\n"
+ "ABABA\n"
+ "BAABA\n"
+ "ABAAB\n"
+ "ABCDE\n"
+ "BBBAA\n"
+ "ABBAB\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}